Wissensdatenbank
Buehl, Kevin
11 Oktober 2017
07 Januar 2018
4.150

Wissensdatenbank

Cisco Catalyst 2960 Switch Switch konfigurieren

Vorbereitung


Schliessen Sie ein RS232 Kabel an einem Windows oder Linux System an und verbinden Sie dieses mit Ihrem Cisco Switch.
Stellen Sie nun eine Verbindung mit der Seriellenschnittstelle her (unter Windows zum Beispiel mit PuTTY).

Konfiguration


Werkseinstellungen


Ich gehe hier von einem Setup auf Werkseinstellungen aus, falls Sie ihren Cisco Switch noch nicht zurückgesetzt haben und dies gerne tun möchten, geben Sie folgende Befehle ein:
# Turn on privileged commands
en
# Write running configuration to memory, network, or terminal
write erase
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
# Halt and perform a cold restart
reload
System configuration has been modified. Save? [yes/no]: yes
Building configuration...
[OK]
Proceed with reload? [confirm]




Hostname ändern


conf t
hostname scat01
exit



VLAN erstellen


scat01(config)#
vlan 4842

scat01(config-vlan)#
name Management

scat01(config-vlan)#
end

scat01#


Trunk konfigurieren

interface GigabitEthernet0/21
switchport mode trunk
switchport trunk allowed vlan all


Interface konfigurieren


conf t
interface GigabitEthernet0/22
no shutdown
switchport mode access
switchport access vlan 4000
end



IP Adresse Konfigurieren


conf t
interface vlan 4000
ip address 192.168.1.11 255.255.255.0
end


SSH aktiveren


conf t
enable password YOURSSHPASSWORD
ip domain-name 4b42.net
crypto key generate rsa
The name for the keys will be: scat01.4b42.net
Choose the size of the key modulus in the range of 360 to 4096 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable...
[OK] (elapsed time was 3 seconds)

scat01(config)#
00:02:35: %SSH-5-ENABLED: SSH 1.99 has been enabled
line vty 0 4
transport input ssh
login local
password 0 Start2017!

line console 0
logging synchronous
login local
exit

username 4b42 password Start2017!
service password-encryption
end
sh run
Building configuration...

Current configuration : 1812 bytes
enable secret 5 $1$hlUB$paG3M2kKtX7cXIyhzS2Sy.
enable password 7 0812584F1B0D5747435C48



Konfiguration speichern


copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]