Wissensdatenbank
Buehl, Kevin
03 Dezember 2017
03 Dezember 2017
3.116

Wissensdatenbank

Icinga Schema version does not match the required version

Inhaltsverzeichnis

Situation


Nach dem Update der Icinga Pakete über das Repository (apt update && apt upgrade) lief mein Icinga 2 Monitoring nicht mehr. Dem Syslog konnte ich folgende Einträge entnehmen:
critical/IdoMysqlConnection: Schema version '1.14.2' does not match the required version '1.14.3' (or newer)! Please check the upgrade documentation at https://docs.icinga.com/icinga2/latest/doc/module/icinga2/chapter/upgrading-icinga-2#upgrading-mysql-db


Lösung


Laut dem obenstehneden Link soll folgender Befehl ausgeführt werden. Laut Fehlermeldung ist das Schema nicht auf Version 1.14.2, allerdings gbit es eine SQL Datei mit der Versionsnummer 1.14.2 also habe ich mein Glück mit der neusten Datei versucht:
mysql -u root -p icinga_ido < /usr/share/icinga2-ido-mysql/schema/upgrade/2.8.0.sql
Enter password:
/etc/init.d/icinga2 restart
[ ok ] Restarting icinga2 (via systemctl): icinga2.service.

Danach konnte ich mein Icinga 2 Monitoring wieder starten.